Configuring WIC-1ADSL on Cisco 2600 with PPPOA and PPPOE

Configuring a Cisco router to use the WIC-1ADSL card is one of the most commonly asked question by people in the Cisco forums. There are some interesting and compelling reasons to use a WIC card instead of connecting PPPOE through the ADSL modem in bridged mode. One of the most compelling reasons is the ability to use advanced QOS features such as interleaving and fragmentation. Because the DSL WIC card shows up as an ATM WAN interface, the router is able to perform those advanced Quality of Service features.  The overhead of encapsulating a packet in PPPOE and sending it to the modem over some length of cable is also a reason to use a WIC card instead of the modem.

It is important to realize that with most ISP’s you can configure the connection to use either PPPOA or PPPOE, the difference in configuration is very subtle however it can save you a couple of bits of overhead as PPPOE is encapsulated more time Than PPPOA.  So without further a due:

First the PPPOE config:

The below is a complete config

Red  is directly related to the WIC DSL config

Green is the rest of the config needed for a bare minimum  working config.

##################################################################################

     Using 5173 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Lord_Yu

!

boot-start-marker

boot-end-marker

!

logging buffered 56000 debugging

no logging console

enable password 7 xxxxxxxxxxxxxxx

!

memory-size iomem 15

clock timezone est -5

clock summer-time est recurring 4 Sun Mar 1:00 4 Sat Oct 1:00

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

ip domain name techinvasion.net

!

no ip bootp server

vpdn enable

vpdn-group 1

 request-dialin

  protocol pppoe

!

interface ATM0/0

 no ip address

 ip route-cache flow

 no atm ilmi-keepalive

 bundle enable

 !

 dsl operating-mode auto

 pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

 !

!

interface FastEthernet0/0

 description LAN INTERFACE

 ip address 10.0.0.254 255.255.255.0

 ip nat inside

 ip tcp adjust-mss 1460

 duplex auto

 speed auto

!

interface Ethernet1/0

 no ip address

 shutdown

 half-duplex

!

interface Dialer1

 description ADSL WAN DIALER

 ip address negotiated

ip mtu 1492

 ip nat outside

 encapsulation ppp

 ip route-cache flow

 ip tcp adjust-mss 1452

 dialer pool 1

 dialer-group 1

 no cdp enable

 ppp authentication chap pap callin

 ppp chap hostname xxxxxxx@xxxxxxxxxx.net

 ppp chap password 7 xxxxxxxxxxxxx

 ppp pap sent-username xxxxxxxx@xxxxxxxxxx.net password 7 xxxxxxxxxxxx

 ppp ipcp dns request

!

ip nat translation timeout 3600

ip nat translation tcp-timeout 1200

ip nat translation finrst-timeout 15

ip nat translation syn-timeout 45

ip nat inside source list 10 interface Dialer1 overload

no ip http server

no ip http secure-server

ip flow-export destination 10.0.0.3 2055

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 permanent

!

!

!

ip access-list extended inbound

 deny   ip 0.0.0.0 0.255.255.255 any log-input

 deny   ip 10.0.0.0 0.255.255.255 any log-input

 deny   ip 127.0.0.0 0.255.255.255 any log-input

 deny   ip 169.254.0.0 0.0.255.255 any log-input

 deny   ip 172.16.0.0 0.15.255.255 any log-input

 deny   ip 192.168.0.0 0.0.255.255 any log-input

 deny   ip 224.0.0.0 15.255.255.255 any log-input

logging 10.0.0.3

access-list 10 permit 10.0.0.0 0.0.0.255

!

line con 0

 password 7 xxxxxxxxxxx

line aux 0

line vty 0 4

 password 7 xxxxxxxxxx

 login

 transport input telnet ssh

line vty 5

 password 7 xxxxxxxxxxxx

 login

!

ntp clock-period 17180335

ntp server 192.43.244.18

ntp server 129.6.15.28

!

end

The Following is the PPPOA Config:

It is not the full config only a partial config.

The Red text is the differences,

Notice how the dialer access-list is different and notice tha lack of the VPDN commands at the top of the config:

####################################################################################

version 12.3

hostname Lord_Yu

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

no logging console

enable password 7

!

memory-size iomem 15

clock timezone est -5

clock summer-time est recurring 4 Sun Mar 1:00 4 Sat Oct 1:00

no aaa new-model

ip subnet-zero

ip cef

!

no ip domain lookup

ip domain name techinvasion.net

!

interface ATM0/0

 no ip address

 ip route-cache flow

 no atm ilmi-keepalive

 bundle enable

 !

 dsl operating-mode auto

 pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

 !

!

interface FastEthernet0/0

 description LAN INTERFACE

 ip address 10.0.0.254 255.255.255.0

 ip nat inside

 ip tcp adjust-mss 1460

 duplex auto

 speed auto

 ipv6 address autoconfig

 ipv6 enable

!

interface Ethernet1/0

 no ip address

 shutdown

 half-duplex

!

interface Dialer1

 description ADSL WAN DIALER

 ip address negotiated

ip mtu 1492

 ip nat outside

encapsulation ppp

 ip route-cache flow

 ip tcp adjust-mss 1452

 dialer pool 1

no cdp enable

 ppp authentication chap pap callin

 ppp chap hostname xxxxxxxxx@xxxxxxxx.net

 ppp chap password 7 xxxxxxxxx

 ppp pap sent-username xxxxxxx@xxxxxxxx.net password 7 xxxxxxxx

 ppp ipcp dns request

!

ip nat inside source list 10 interface Dialer1 overload

no ip http server

no ip http secure-server

ip flow-export destination 10.0.0.3 2055

ip classless

access-list 10 permit 10.0.0.0 0.0.0.255

dialer-list 1 protocol ip permit

Tags: , ,

One Response to “Configuring WIC-1ADSL on Cisco 2600 with PPPOA and PPPOE”

  1. DNS Port Says:

    port…

    […]Techinvasion.net » Blog Archive » Configuring WIC-1ADSL on Cisco 2600 with PPPOA and PPPOE[…]…

Leave a Reply

You must be logged in to post a comment.

Categories
Support Our site